How to install LibiMobileDevice apps on a MAC – OSX El Capitan 10.11 – The easy way

How to install LibiMobileDevice apps on a MAC – OSX El Capitan 10.11
In this tutorial I am going to show you how to install libimobiledevice applications you got used to from Windows on your MAC. This is compatible with latest OSX Version (El Capitan 10.11) and it recognizes all iOS-powered devices such as iPAD Pro, iPAD Air, iPhone 6S, 6S Plus, 5 and so on, so there is no compatibility issue even if it is a homebrew.

The applications are being called via Terminal app, which is embedded into the OSX, so you just need to call the appropriate app after you install libimobiledevice and you are good to go.

The tutorial shows exactly how to download the content from GitHub via Terminal Ruby command (XCODE-powered), therefore it is easy for you to install all dylibs and kexts automatically.

In the tutorial I also test 4 of the apps, the backup solutions, the pair and the ideviceinfo to gather details about my connected device, and everything works as it should.

Are you ready to export your CFW project to OSX?

Command for downloading HomeBrew from GitHub:

Command to install libimobiledevice:
brew install libimobiledevice


About GeoSn0w

Expert Programmer | Security Analyst | Content Creator | Web Designer I like to bring the latest news from the iOS / iDevice / Jailbreak battlefield to you in a beautiful manner :) I hope you like the site. If you do, don't forget to check out my channel :)

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>