iOS 14.4.2 / 14.4.1 / 14.4 JAILBREAK BIG NEWS: New Important LPE Vuln ANNOUNCED To Be Released Soon!

In today’s video, I have great news for those of you with newer iPhones like iPhone 11, iPhone 12, iPhone XS, XR, XS Max, and so on, but also for the rest with older devices. A brand new Jailbreak vulnerability was announced to be released in the near future for iOS 14.4.2, iOS 14.4.1, and iOS 14.4 which is compatible with all devices including A12, A13, and A14. With a bit of luck, we might be able to use this new LPE vulnerability to update Unc0ver and Taurine Jailbreak.

So if you’re interested in jailbreak your iOS 14.2.1, iOS 14.4.1, or iOS 14.4 devices with Unc0ver or Taurine as soon as possible, it’s best to avoid updating to iOS 14.5. FreeTheSandbox movement has announced the new bug on Twitter and they said we should stay on iOS 14.4.2 or lower if we’re interested in it. As such, it’s best to disable updates and stay away from iOS 14.5 if you wanna jailbreak soon. The bug has apparently been patched in iOS 14.5 so it doesn’t work there.

As always, do not forget to SUBSCRIBE to stay updated with the latest #iOS and #Jailbreak news, updates, and tutorials!
~ GeoSn0w


About GeoSn0w

C#, C, Objective-C Programmer | Beginner iOS Security Researcher | Content Creator | Web Developer I like to bring the latest news from the iOS / iDevice / Jailbreak battlefield to you in a beautiful manner :) I hope you like the site. If you do, don't forget to check out my channel :)